Resolved
The issue has been resolved and the system is operating normally.
Identified
EU & US fully operational
Identified
We're aware of an issue affecting file uploads and Word Add-ins. Our team is actively working on a fix and we'll post updates here as we have them.